Ntevl probe log shows "Waiting.. current job Queue count..30000 reached 'max_job_queue_size' limit 30000"
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Ntevl probe log shows "Waiting.. current job Queue count..30000 reached 'max_job_queue_size' limit 30000"

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Article ID: 407037

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

Ntevl probe not reporting new event alarms

Ntevl.log shows "Waiting.. current job Queue count..30000 reached 'max_job_queue_size' limit 30000"

Environment

DX UIM: all supported versions

Cause

In the Windows Event log, there were a large number of the same event ID in a short period of time causing the job queue to exceed its max value as seen in the ntevl.log below:

Aug 11 10:13:08:767 [160432] ntevl: evlStoreEventsInQueue(): current Job Queue count.. 30000
Aug 11 10:13:08:767 [160432] ntevl: evlStoreEventsInQueue(): Job queue exhausted as Incoming events are more.. Increase number of threads to process events fast..
Aug 11 10:13:08:767 [160432] ntevl: evlStoreEventsInQueue(): Waiting.. current job Queue count..30000 reached 'max_job_queue_size' limit 30000

Resolution

Workaround:

Increase the max_job_queue_size to 40000

Use any of the following methods based on your environment:

1- Via Infrastructure Manager
Select NTEVL Raw Configure> select setup section> then edit the max_queue_size

2- If you use MCS then edit Setup ntevl (Enhanced) and update the Max Queue Size