NSX plugin not available in vCenter vSphere Client.
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NSX plugin not available in vCenter vSphere Client.

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Article ID: 406976

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Updated On:

Products

VMware NSX

Issue/Introduction

Environment

VMware NSX

Cause

Previously, the affected vCenter was added as a Compute Manager to an existing NSX Manager. Though the Compute Manager was removed, the NSX extension "com.vmware.nsx.management.nsxt" is still registered on the vCenter.
It can be checked by navigating to the vCenter MOB page - https://vcenter_fqdn-or-ip/mob ==> click on "content" ==> click on "ExtensionManager" ==> click on "FIndExtension" ==> In the Value field for "extensionKey", enter "com.vmware.nsx.management.nsxt" and click on "Invoke Method". If the extension is registered, it will show the details. Otherwise, the result will show as Void.

The NSX landing page is intentionally hidden in the following scenarios:

  • When the solution is installed on at least one linked vCenter Server.
  • When the NSX remote plugin fails on all linked vCenter Servers. This may occur if the NSX appliance is deployed, but the plugin itself has not been successfully installed.
  • When all linked vCenter Servers have an existing legacy NSX registration.
  • When the solution is running in VMware Cloud Foundation (VCF) or VMware Cloud on AWS (VMC) environments.

Resolution

To resolve the issue and make the NSX plugin available again, follow the below steps: