Virtual machine with RDM disks fails to power on from the vSphere Client with the error "No host is compatible with the virtual machine"
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Virtual machine with RDM disks fails to power on from the vSphere Client with the error "No host is compatible with the virtual machine"

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Article ID: 406793

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Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

Symptoms:

  • Virtual machines with RDM disks fails to power on from the vSphere Client with the error "No host is compatible with the virtual machine"

  • Power on operation initiated from the Host Client completes successfully

  • This issue is observed after performing an activity on the backend storage which involves unmapping the RDM disks and the device backing the datastore on which the rdmp files are stored resulting in the devices entering a PDL state

  • Also the virtual machine configuration file is on a different datastore and the rdmp files are on a different datastore

  • If VM monitoring is enabled under vSphere HA setting, vSphere HA fails to restart the virtual machine after the devices are mapped back to the ESXi host.

  • After ensuring that the devices are mapped and accessible on the host, initiating a power on operation from the vSphere Client fails with the above mentioned error indicating that the vcenter server is unable to detect the status change of the RDM devices.

Environment

VMware vCenter server 8.x

Cause

The virtual machine fails to power on from the vSphere Client whenever the RDM disks attached to virtual machine is registered or mapped to the ESXi hosts after the datastore which contains the rdmp files is registered and mounted on the ESXi hosts. In addition to this, it is observed that the vcenter server is unable to detect the status change of the RDM devices specifically when the configuration file of the vm is on a different datastore and the rdmp files are on the different datastore. 

Resolution

We do not have a permanent fix for the vcenter behaviour at this moment and this is still under investigation, but we can follow the below workarounds:

Whenever you encounter this issue, login to the Host client of the host where the virtual machine is registered and power on the vm

OR

Take a ssh to the ESXi host and reload the vmx file of the virtual machine and then initiated power on from the host client. (Refer: Reloading a vmx file without removing the virtual machine from inventory)

OR

Keep the configuration file of the virtual machine and the rdmp files on the same datastore.