After importing new Data Center Security (DCS) license error cannot invoke "Object.,getClass()" because "date" is null is displayed
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After importing new Data Center Security (DCS) license error cannot invoke "Object.,getClass()" because "date" is null is displayed

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Article ID: 406744

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Updated On:

Products

Data Center Security Server Advanced

Issue/Introduction

You have tried to import the new DCS 6.10 licenses, and after successful import you are unable to view the license page.

The error Cannot invoke "Object.getClass()" becuase "date" is null is displayed. 

 

Environment

DCS 6.10 upgraded from DCS 6.9.3

Cause

There was a perpetual licence present in DCS Management Server before the upgrade to version 6.10, and the upgrade resulted in the DCS Management Server console being unable to read the formerly imported license. 

Resolution

To resolve the issue, please follow the steps below:

1. Perform a full backup of the SCSPDB database

2. Stop the DCS Management Server service

3. Execute the SQL query below:

delete from scspdb.dbo.[Settings.License] where scspdb.dbo.[Settings.License].rid != 0

4. Delete all licenses from the installedLicenses directory on DCS Management Server

{Drive}:\Program Files\Symantec\Symantec Data Center Security\Server\Management\installedLicenses
 

5. Start DCS Management Server service

6. Login to DCS console and import the license .slf files