Local DB login not working
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Local DB login not working

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Article ID: 406696

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Updated On:

Products

VMware Smart Assurance

Issue/Introduction

  • DB password is unknown, local DB login is not working.
  • AS to DB connectivity is failing. 
  • No communication between AS and DB.
  • NCM GUI login is failing.

Environment

NCM - 10.1.x/24.3.x

Cause

DB has different password but AS has 'empty DB password/No password' 

Resolution

To verify DB password in AS:

  1. source /etc/voyence.conf
  2. Navigate to $VOYENCE_HOME/ncmcore/webapps/ncm-webapp/WEB-INF/classes/, open jdbc.properties.
  3. Make note of encrypted password in jdbc.password
  4. Navigate to $JAVA_HOME/bin and run 
    ./java -cp $VOYENCE_HOME/tools NCM -d <Encrypted password from jdbc.properties/Step 3>
  5. It will show DB password, cross verify it using Cannot connect to the Smarts NCM database because the password is unknown
  6. Both the passwords must be same.
  7. If passwords are not same, follow KB: Changing the Database user password using the ./password-change.pl script fails to change DB password and sync it. 

No Password/Empty result in Step 4 and 5:

  1. source /etc/voyence.conf
  2. Navigate to $VOYENCE_HOME/conf/setup/, open install.properties
  3. Make note of encrypted password in DBPW
  4. Paste it in jdbc.password of $VOYENCE_HOME/ncmcore/webapps/ncm-webapp/WEB-INF/classes/jdbc.properties file.
  5. start vcmaster service as
    systemctl restart vcmaster