Autosys Agent NOT coming up in DR Instance
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Autosys Agent NOT coming up in DR Instance

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Article ID: 406646

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Updated On:

Products

Workload Automation Agent ESP dSeries Workload Automation - Business Agents (dSeries) ESP dSeries Workload Automation - System Agent (dSeries)

Issue/Introduction

Need assistance in bringing up the Autosys Agent in a Disaster Recovery(DR) Instance running on Linux OS.

The Autosys Agent didn't come up even after the DR Database connectivity restored.

Environment

Workload Automation Agent

Cause

Agent failed to start due to a connection issue with the Peoplesoft Oracle database. The ORA-12505 error confirms an underlying network problem preventing the database from registering with its listener.

defaultlog_agent.log:

07/31/2025 16:02:27.319+0000 1 main.MainThread.PsDbHandler$PsDbHandlerSingleton.<clinit>[:468] - cybermation.plugins.ps.PsConfigException: Failed to connect to PS DB using: jdbc:oracle:thin:@example.com:1521:mydatabase

peoplesoft.log:

07/31/2025 16:02:27.318+0000 1 main.MainThread.PsDbHandler.<init>[:350] - java.sql.SQLException: Listener refused the connection with the following error:
                                                                          ORA-12505, TNS:listener does not currently know of SID given in connect descriptor

Caused by: oracle.net.ns.NetException: Listener refused the connection with the following error:
                                                                          ORA-12505, TNS:listener does not currently know of SID given in connect descriptor

Resolution

Collaborate with your Database Administrator (DBA) and/or Network team to verify network connectivity, including firewall rules, between the agent in your Disaster Recovery (DR) instance and the Peoplesoft Oracle database server on port 1521.