Upgrading Aria Operations through Lifecycle Manager fails with LCMVROPCONFIG20066
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Article ID: 406639
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Updated On:
Products
VCF Operations/Automation (formerly VMware Aria Suite)
Issue/Introduction
Upgrading Aria Operations through Lifecycle Manager fails with "Unknown Host Exception".
In Lifecycle Manager the Aria Operations environment shows the primary node as a data node.
Environment
Aria Operations 8.18.x
VMware Aria Suite Lifecycle 8.18.0
Cause
Aria Operations admin portal displays correct primary, replica, and data nodes correctly but the casa.db.script has incorrect entries.
VMware Lifecycle manager is missing the master node under the "Primary, Replica, Witness" menu.
Resolution
To fix the issue the files need to be updated correct entries:
- Log into the Aria Operations portal as admin.
- Verify the role or the primary and replica nodes.
- Click "Take Cluster Offline" to bring the cluster down.
- Take a snapshot of all the nodes once the cluster is offline.
- Log into each of the node as root.
-
cd /storage/db/casa/webapp/hsqldb
- Make a backup of the file:
cp -p casa.db.script casa.db.script.backup
- Edit the casa.db.script and locate the the primary node which will look like:
"is_admin_node": false,"ip_address":"<primary node>"
- Change the admin node to true and save the file:
"is_admin_node":true
- Save the file.
- From the Aria Operations admin UI bring the cluster online.
- From VMware Lifecycle Manager go to Lifecycle Operations > Environments and View Details of the VMware Operations environment.
- Click the Operations tab up top.
- Click the "Primary, Replica, Witness" menu button and verify the master and replica are correct.
- Install the patch again by clicking the 3 dotted buttons and going to Patches > Install Patch.
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