Storage Policy IOPS is not updated when changing the storage policy
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Storage Policy IOPS is not updated when changing the storage policy

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Article ID: 406582

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Updated On:

Products

VMware Cloud Director

Issue/Introduction

  • When users modify storage policy on a Virtual machine, the IOPS Limit and Reservation doesn't work.
  • IOPS Limt and IOPS Reservation show empty - character.
  • Changing storage policy on a VM resets the IOPS value to blank.
  • IOPS values are not displayed correctly when a change to the disk is made

Environment

VMware Cloud Director 10.6.1.1

Cause

This issue can occur during actions such as adding a hard disk to a VM or making a storage policy change on an existing disk. When the hard disk settings are being saved the disk id can be seen as null. As the IOPS Limit and IOPS reservation fail to be calculated during this time it results in a value of 0 being set.

Resolution

This is a known issue which Broadcom is aware of and will be fixed in a future release of VMware Cloud Director.

To workaround the issue a reconfigure task can be issued against the VM without making any changes. This will reapply the expected IOPS values. An example of performing this action in the user interface would be to:

  1. In the Tenant UI under "Hardware -> Hard Disks" click on the hard disk of the impacted VM. 
  2. Click the 'Edit' button.
  3. In the modal window, click the SAVE button without making any changes.
  4. Validate that the expected IOPS Limit and Reservation and repopulated.