DS 8.x - When updating SBS/PXE Preboot images, it fails with an error in the logs. The file exists (0x00000050)
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DS 8.x - When updating SBS/PXE Preboot images, it fails with an error in the logs. The file exists (0x00000050)

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Article ID: 406577

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Updated On:

Products

Client Management Suite Deployment Solution

Issue/Introduction

When performing an update of the preboot image, you might encounter a specific error message in the Agent logs of the Site Server

Preboot Cfg: PXE server failed to update image '%Path to SBS Images\Image Name\x64', error: The file exists (0x00000050)

Additionally, in the DISM log (C:\Windows\Logs\Dism\), we can see an error during the unmount process with exit code 0x80070032.

Environment

ITMS 8.x

Deployment Solution 8.x

Cause

Caused by an existing dism mounted image not being properly cleaned. It might be caused by the race conditions, or Antivirus blocking or delaying the process.

Resolution

1. After re-creation and/or update have failed. And no Bootwiz or Dism processes are running in Windows Task Manager - Check Windows registry on the affected PXE server (might be the SMP server itself) in Hive "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WIMMount\Mounted Images" that there are no orphan records.

(same can be checked using cmd dism /get-mountedwiminfo)

2. In the CMD prompt as Administrator - run the "Dism /Cleanup-Mountpoints" command - and verify that registry records have been removed. Or run "dism /get-mountedwiminfo" for results.

3. If registry entries are still there. You might try to perform a Server reboot or delete those records manually.

4. Restart image recreation process - which then should properly finish.

If the issue persists. Please collect the dism log (C:\Windows\Logs\Dism\) and report to Support for further review and investigation.