Unable to query vSAN health information. Check vSphere Client logs for details. error seen when navigating from "Learn more" in a vCenter alarm
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Unable to query vSAN health information. Check vSphere Client logs for details. error seen when navigating from "Learn more" in a vCenter alarm

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Article ID: 406514

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Updated On:

Products

VMware vCenter Server VMware vCenter Server 8.0

Issue/Introduction

  • vCenter has triggered alarms 

    Skyline Health has detected issues in your vSphere environment
    vSphere Health detected new issues in your environment




  • Alarms continually return after being Acknowledged or Reset to Green

  • Selecting Learn more in the alarm navigates to the Skyline Health page showing the following error banner


    Unable to query vSAN health information. Check vSphere Client logs for details.




  • Navigating manually to Skyline Health does not return this error

Environment

vCenter 8.x

Cause

Navigating from the "Learn more" link does not set the context object properly causing the error.  

Resolution

The  Unable to query vSAN health information. Check vSphere Client logs for details.  error when navigating from the "Learn more" is a known issue that affects vCenter Server 8.0U3.   It is cosmetic only and does not affect functionality.


Workaround

Prevent the vCenter Server alarms

  1.   Navigate to Skyline Health manually
  2.   Reviewing any findings and resolve them or Silence Alert
  3.   Acknowledge or Reset to Green the vCenter alarm on the vCenter Summary Page

    or

  4.  Perform a browser refresh to pull up the Skyline Health page properly after navigating from "Learn more"