Error: "Failed to do request, ERROR: Get "https://<ecs_fqdn>:4443/login": net/http: TLS handshake timeout" causes OSE service startup failure
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Error: "Failed to do request, ERROR: Get "https://<ecs_fqdn>:4443/login": net/http: TLS handshake timeout" causes OSE service startup failure

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Article ID: 406438

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Updated On:

Products

VMware Cloud Director

Issue/Introduction

  • VMware Cloud Director Object Storage Extension (OSE) UI is not accessible in the Cloud Director portal.
  • OSE is configured with Dell ECS as the S3 object storage platform.
  • Restarting the OSE service on the OSE server fails with a timed out error:

    ose service restart

    Stop OSE middleware successfully
    Start OSE Service:  #m#s [====================================================================] 100%
    Timed out, please refer the log file under /opt/vmware/voss/log to get more detail!
    Or check if the jvmargs is valid(ose jvmargs show)

  • Validating the OSE configuration on the OSE server shows an error validating the ECS Admin Service:

    ose config validate

    +----------------------+-------------+---------------+-------------------------------------------------------+
    |         Name         |   Required  |   Validation  |                         Detail                        |
    +======================+=============+===============+=======================================================+
    |     OSE Endpoint     |      Y      |     Valid     |                                                       |
    +----------------------+-------------+---------------+-------------------------------------------------------+
    |       Database       |      Y      |     Valid     |                                                       |
    +----------------------+-------------+---------------+-------------------------------------------------------+
    |      Certificate     |      Y      |     Valid     |                                                       |
    +----------------------+-------------+---------------+-------------------------------------------------------+
    |    Cloud Director    |      Y      |     Valid     |                                                       |
    +----------------------+-------------+---------------+-------------------------------------------------------+
    |    Platform - ECS    |      Y      |     Valid     |                                                       |
    +----------------------+-------------+---------------+-------------------------------------------------------+
    |   ECS Admin Service  |      Y      |    Invalid    |   do request, ERROR: Get "https://<ecs_fqdn>:4443/lo  |
    |                      |             |               |   gin": net/http: TLS handshake timeout               |
    +----------------------+-------------+---------------+-------------------------------------------------------+
    |    ECS S3 Service    |      Y      |     Valid     |                                                       |
    +----------------------+-------------+---------------+-------------------------------------------------------+

  • The /opt/vmware/voss/log/ose-keeper.log on the OSE server shows an error of the form:

    <timestamp> ecs.go:35: [########] Failed to do request, ERROR: Get "https://<ecs_fqdn>:4443/login": net/http: TLS handshake timeout

  • Attempting to reach the ECS Admin Service via curl from the OSE server times out or fails to complete similar to the following:

    curl -k -v https://<ecs_fqdn>:4443/login

      Trying #.#.#.#...
    TCP_NODELAY set
    Connected to <ecs_fqdn> (#.#.#.#) port 4443 (#0)
    ALPN, offering h2
    ALPN, offering http/1.1
    successfully set certificate verify locations:
      CAfile: /etc/pki/tls/certs/ca-bundle.crt
      CApath: none
    TLSv1.3 (OUT), TLS handshake, Client hello (1):

Environment

  • VMware Cloud Director 10.6.x
  • VMware Cloud Director Object Storage Extension 3.1.x

Cause

This issue occurs if there is a network issue causing connectivity from the OSE server to the Dell ECS Admin Service endpoint to fail.

The OSE service cannot start if the configured Dell ECS Admin Service cannot be reached.

Resolution

Ensure that the Dell ECS Admin Service is running and reachable on the network from the OSE server.

For example, confirm that there is no firewall, load balancer or other network configuration that could be blocking connectivity.

Once the Dell ECS Admin Service is reachable from the OSE server then the OSE service will be able to start.

Additional Information

For more information on the network requirements, see the OSE documentation on ECS
Deployment Requirements.