Unable to execute commands thru WCC ECLI

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Article ID: 40631

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Updated On:

Products

CA Workload Automation AE - Business Agents (AutoSys) CA Workload Automation AE - Scheduler (AutoSys) CA Workload Automation Agent

Issue/Introduction

Issue : 

When trying to execute an autosys command in the CA Workload Control Center (WCC) using the 'Enterprise Command Line Interface (ECLI), I'm getting below response 

1. in the output field window:

The command could not be executed. Command processing exception encountered.

2. in the errors field window: 

org.apache.http.conn.HttpHostConnectException: Connection to https://<hostname>:5250 refused

 

Environment:  

WCC 11.3 and above

 

Cause: 

The iGateway process isn't running. WCC uses the igateway to communicate with Autosys when using ECLI.

 

Resolution/Workaround:

Start igateway on the Autosys machine.

a) on Windows, launch 'services.msc' and start service 'CA iTechnology iGateway 4.7' service

b) on Unix/Linux, run $IGW_LOC/S99igateway start

 

 

Environment

Release: ATSYHA99000-11.3.6-Workload Automation AE-High Availability Option
Component: