Deploying Aria Operations for logs using Aria Suite Lifecycle fails with error LCMVRLISYSTEM45018: Unable to connect to host. Check host details and retry.java.net.ConnectException: Connection timed out (Connection timed out)
search cancel

Deploying Aria Operations for logs using Aria Suite Lifecycle fails with error LCMVRLISYSTEM45018: Unable to connect to host. Check host details and retry.java.net.ConnectException: Connection timed out (Connection timed out)

book

Article ID: 406304

calendar_today

Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

  • When trying to deploy Aria Operations for logs through Aria Suite Lifecycle we see the below failure

     
    IO error , Check VMware Aria Operations for Logs instance is up and running.

  • /var/log/vrlcm/vmware_vrlcm.log on Aria Suite Lifecycle node has the following entries:

    2025-07-17T06:25:30.101Z ERROR vrlcm[1667] [pool-3-thread-38] [c.v.v.l.p.v.StartNewVRLIInstallTask]  -- Exception while installing new VMware Aria Operations for Logs. Waiting  before retrying
    java.net.ConnectException: Connection timed out (Connection timed out)
            at java.base/java.net.PlainSocketImpl.socketConnect(Native Method) ~[?:?]
            at java.base/java.net.AbstractPlainSocketImpl.doConnect(Unknown Source) ~[?:?]
            at java.base/java.net.AbstractPlainSocketImpl.connectToAddress(Unknown Source) ~[?:?]
            at java.base/java.net.AbstractPlainSocketImpl.connect(Unknown Source) ~[?:?]

  • Checking the Aria Operations for logs VM, it is deployed successfully.

  • Port connectivity between Aria Suite Lifecycle and Aria Operations for logs on port 22 and 443 works. 

Environment

Aria Operations for logs 8.x

Aria Suite lifecycle 8.x

Cause

  • The deployment failure is due to incomplete network connectivity between the Aria Suite Lifecycle VM and the Aria Operations for Logs VM.

  • While basic ports (22 and 443) are open, additional required ports and ICMP protocol are not enabled, leading to communication issues and timeout errors during the post-deployment configuration and validation stages.

Resolution

  • Ensure the following network requirements are met between the Aria Suite Lifecycle VM and the Aria Operations for Logs VM as per VMware Aria Suite Lifecycle Product documentation :

    Open the following ports between Aria Suite Lifecycle -> Aria Operations for logs:
    443
    9543
    16520
    22

  • Enable ICMP protocol between the two VMs (for ping/heartbeat checks).

  • After updating the firewall rules, retry the Aria Operations for Logs installation via Aria Suite Lifecycle UI.