baseline_engine.QOS_MESSAGE queue filling up disk and baseline_engine probe is red
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baseline_engine.QOS_MESSAGE queue filling up disk and baseline_engine probe is red

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Article ID: 406228

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

Symptoms:

  • disk filling up/full on secondary hub
  • baseline_engine.QOS_MESSAGE queue backed up/not draining
  • folder ($UIM_HOME)/nimsoft/hub/q/baseline_engine.QOS_MESSAGE full of .sds files
  • baseline_engine probe is red
  • controller.log shows:  (command = ../../../jre/(some path)/bin/java  error = (3) The system cannot find the path specified.

 

Environment

DX UIM 23.4.3
hub 23.4.3

Cause

corrupted or missing java_jre installation

Resolution

The first thing to try is simply deploying the latest version of the java_jre probe to the robot.

Then deactivate baseline_engine and activate it again, and check the queue to ensure it is draining.

If this does not resolve the issue, check under the ($UIM_HOME)/Nimsoft/jre/ folder and ensure that the path given in the error message actually exists, with a /bin folder, and a /bin/java or java.exe (if Windows) present in the folder.

Check to ensure the JRE_HOME variable is set correctly and matches the same path.

 

Additional Information