Clarity Licensing Change in 16.2.3+
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Clarity Licensing Change in 16.2.3+

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Article ID: 406204

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Updated On:

Products

Clarity PPM SaaS Clarity PPM On Premise

Issue/Introduction

The new logic of the licensing portlet counts licenses includes resources that left a while ago.

  • Instead of counting the month of the timesheet period as the licensing period, the portlet is counting the month of timesheet posting as the licensing period. 
  • We have an example of a person who left in August 2024.
    • Some of their old (July/August 2024) timesheets remained unsubmitted and were submitted & posted this month (July 2025) as part of year-end close.
    • The user shows up on this month's license report as having consumed a restricted license when he's been gone almost a year.

Environment

Clarity 16.2.3 and higher

Cause

Licensing design change that went in 16.2.3

Resolution

In previous releases, Clarity counted user licenses based solely on assigned access. We have enhanced how restricted users are identified for more accurate license management.

What's New?

  1. Enhanced identification of restricted user count, to include users in Clarity transactions or posted timesheet tables, for accurate license management. 
  2. Introduced two new fields in the 'User List by License Type': User Status and Sub License Type.

How do we calculate the user license types within Clarity?

Based on the following conditions, the Clarity User will be counted as Full/Restricted/View License Type:

Sl. No.

User's Status

Access Rights by License Type

[Required At least One Access Right ]

Result

View

Restricted

Full

01.

Active

 

 

    

User counted under 'Full' license type

02.

Active

 

        

User counted under 'Restricted' license type

03.

Active/Locked /Inactive

    

 

Users who are not already counted under the Full license type and are involved in either the Clarity transactions tables or posted timesheets within the calendar month, regardless of their status, are counted under the 'Restricted' license type.

04.

Active

    

User counted under 'View' license type

Know About the New Fields

The Clarity “User List by License Type” portlet has been enhanced to display two new columns to help classify a user's license type. Users will need to manually configure their view to include these new columns. 

  • User Status: Indicates the user's “Status”
  • Sub License Type: Indicates the conditions that resulted in counting the user under Restricted license type. This column will only have value when reviewing “Restricted” license count details. The following values will be displayed under this field:
    • User with restricted access: Includes users with the status of “Active” AND have been granted at least one access right that is of license type of “Restricted” AND does not have any access right that is of license type of “Full”
    • User in transaction tables: Users are not already counted in the Full license type AND are included in the Clarity transactions tables within the calendar month regardless of their status.
    • User with Posted Timesheet: Users are not already counted in Full license type AND have posted timesheets within the calendar month regardless of their status.

Consider the following scenarios to understand how user license types are calculated within Clarity:

Scenario 01: Transition from View Only to Restricted License Type

When a user classified as View Only has an unposted transaction, executing the Post to WIP job changes the license type to Restricted based on the transaction history.

Scenario 02: Transition from Restricted Access to Posted Timesheet in Sub License Type

If a user's status changes from Active to Inactive, but they have a posted timesheet, the Post Timesheet job updates the Sub License Type from 'User with Restricted Access' to 'User with Posted Timesheet'.

 

More Information can be found here: Broadcom Documentation - Release Notes