SDDC Manager returns a 'NetworkPool Internal Server Error' during IP removal or when querying Network Pools and Hosts."
search cancel

SDDC Manager returns a 'NetworkPool Internal Server Error' during IP removal or when querying Network Pools and Hosts."

book

Article ID: 406169

calendar_today

Updated On:

Products

VMware SDDC Manager

Issue/Introduction

Under hosts it shows that the API request to network-pools fails with a NetworkPool Internal Server Error:

  • http://127.0.0.1/v1/network-pools" api: Encountered error requesting http://127.0.0.1/v1/network-pools api: NetworkPool Internal Server Error
  • Log /var/log/vmware/vcf/commonsvcs/vcf-commonsvcs.log has the following exception:

YYYY-MM-DD:00:07.147+0000 ERROR [common,6438ef943ff645a8,b4ae] [c.v.e.s.e.h.LocalizableRuntimeExceptionHandler,http-nio-127.0.0.1-7100-exec-2] [G3AGTQ]
NETWORKPOOL_INTERNAL_SERVER_ERROR NetworkPool Internal Server Error com.vmware.evo.sddc.networkpool.common.NetworkPoolApiException: NetworkPool Internal Server Error at com.vmware.evo.sddc.networkpool.rest.api.controller.v1.NetworkPoolsApiController.getNetworkPools(NetworkPoolsApiController.java:107) at jdk.internal.reflect.GeneratedMethodAccessor583.invoke(Unknown Source) at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) at java.base/java.lang.reflect.Method.invoke(Method.java:569)

Also, removing the IPs from the Network pool throws the below error:

{"errorCode":"NETWORKPOOL_INTERNAL_SERVER_ERROR","arguments":[],"message":"NetworkPool Internal Server Error","causes":[{"type":"java.lang.NullPointerException","message":"Cannot invoke \"java.util.List.removeAll(java.util.Collection)\" because the return value of \"com.vmware.evo.sddc.networkpool.service.model.Network.getFreeIplist()\" is null"}],"referenceToken":"#####"}

This can occur specifically after commissioning hosts from vCenter, regardless of whether the vcf_brownfield.py sync option was used afterward.

Environment

VMware Cloud Foundation 5.2.x

Cause

This is due to the workflow of migration to a network pool: Duplicate IP addresses are removed from the other networks in the old network pool. If a single network in the network pool is either of the conditions below:

  1. Covering used ips by the domain
  2. The issue stems from IP Ranges being passed as an empty list when IPs are static. This results in a NullPointerException during the processing of ipRangeList.

 

Resolution

Please contact Global Support Services (GSS) to verify if your environment is impacted by this specific database inconsistency. Upon confirmation, GSS will remediate the issue by updating the affected database column to the required list format. A permanent fix is available in the VCF 9.0 release.