Checking the Network pools or the Hosts under SDDC Manager returns an error - "NetworkPool Internal Server Error"
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Checking the Network pools or the Hosts under SDDC Manager returns an error - "NetworkPool Internal Server Error"

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Article ID: 406169

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Updated On:

Products

VMware SDDC Manager

Issue/Introduction

Under hosts it shows that API request to network-pools fails with NetworkPool Internal Server Error:
"http://127.0.0.1/v1/network-pools" api: Encountered error requesting http://127.0.0.1/v1/network-pools api: NetworkPoool Internal Server Error

 


Log /var/log/vmware/vcf/commonsvcs/vcf-commonsvcs.log has the following exception 
2026-01-07T21:00:07.147+0000 ERROR [common,6438ef943ff645a8,b4ae] [c.v.e.s.e.h.LocalizableRuntimeExceptionHandler,http-nio-127.0.0.1-7100-exec-2] [G3AGTQ] NETWORKPOOL_INTERNAL_SERVER_ERROR NetworkPoool Internal Server Error
com.vmware.evo.sddc.networkpool.common.NetworkPoolApiException: NetworkPoool Internal Server Error
        at com.vmware.evo.sddc.networkpool.rest.api.controller.v1.NetworkPoolsApiController.getNetworkPools(NetworkPoolsApiController.java:107)
        at jdk.internal.reflect.GeneratedMethodAccessor583.invoke(Unknown Source)
        at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        at java.base/java.lang.reflect.Method.invoke(Method.java:569)



This can happen particularly after commissioning hosts from vCenter, and regardless of vcf_brownfield.py sync option was used afterwards.

Environment

VMware Cloud Foundation 5.2.x

Cause

This is due to the workflow of migration to a network pool: Duplicate IP addresses are removed from the other networks in the old network pool. If a single network in the network pool is either of the conditions below:
1) Is only covering used ips by the domain
2) New network's ips remain the same, then the ipRanges are left as empty list

This leads to a NullPointerException for the ipRangeList, thus causing the problem.

Resolution

Contact GSS to review the database and confirm this is the applicable issue, and for resolution.

Once it is confirmed that this is the applicable issue, GSS will be modifying the related table in the Database table column with the expected type (list).

The issue is resolved in VCF 9.0 release.