Missing dashboard in NPC
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Missing dashboard in NPC

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Article ID: 40609

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Updated On:

Products

CA Network Flow Analysis (NetQos / NFA)

Issue/Introduction

Issue/Problem/Symptoms: 

Customer has an interface utilization graph that is available in NetVoyant Console (or another data source), but it is not able to display it in NPC. Customer may have a number of other data sources also attached to NPC.

Environment:  

NetVoyant and NPC

Cause: 

Some interface data may be outdated from one of the attached data sources and thus can cause conflicting information in the NPC dashboard. The NPC can pull the wrong interface if the interface data is no longer coherent across all attached data sources.

Resolution/Workaround:

To resolve this interface inconsistency issue, an investigation on some NPC database tables is warranted. The following NPC table holds device information:

dst_device

The following NPC table holds interface information:

dst_interface

The following NPC table holds device and interface membership information:

item_members;

The following query will pull the device information:

select * from dst_interface where dev_alias='device name';

The following query will pull the list of interfaces from a given device:

select * from dst_interface where itemid in (select childid from item_members where parentid='itemid returned above');

You need to compare the entries returned by several data sources. You can take the IfIndex as reference as this value should be unique for a given device, check if interface description match, if not, then interface information provided by other data sources is not consistent and that data source must be investigated further. You can find the data source by looking at the sourceid field returned from the above query. You can relate sourceid and data source IP address by querying the data_sources2 table as follows:

select * from data_sources2;

Identify the problem with the data source and once it is fixed, synchronize that data source from the NPC and check if the problem is resolved.

For further help and information please contact CA Support.

Environment

Release: PCSTAS99000-6.1-NetQoS-Performance Center-Stand-Alone-Server
Component: