"MQ_error_service_not_available"
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"MQ_error_service_not_available"

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Article ID: 40582

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Updated On:

Products

CA Business Service Insight

Issue/Introduction

Problem: 

In the form of Adapters, I receive the following error:

T_APPLICATION_GROUPS, Communication error: Problem performing operation on queue.

Queue: "OG Adapter Listener"

Operation: "Open Queue"

Addicional error information:

Friendly Name: MQ_ERROR_SERVICE_NOT_AVAILABLE

  

Cause: 

Returned when Message Queuing cannot find the queue on a three tier installation. Such queues include public queues not registered in the directory service and Internet queues that do not exist in the MSMQ namespace. This error is also returned when the user does not have sufficient permissions to perform the operation.

 

Resolution:

When you stop or start an adapter, this places a message in the adapter listener queue. This is an MSMQ on the application server. The adapter listener service then picks up this message and takes the appropriate action. Either you are pointing to the wrong machine where the queues reside, you do not have rights to the queues, they are full, or not properly created at all.

 

  1. First, in the GUI go to "Administration", "Site settings", and "advanced". click on the group called "Queues". Make sure that the three Queue settings all point to the application server Name.

  2. Make sure that from the web server you can resolve that Name and ping it. That will likely solve the problem, but if not...

  3. On the app server, open MSMQ's (under server manager and features) and open private queues. Make sure you can see all 4 of the BSI queues

  4. Right-click on each of the four queues and go under the security tab. Be sure that the user account your services run under and the website runs under (in it's identity tab) has full rights to the queues.

  5. Click on the private queue group and look at the message counts for each of the queues on the right. Be sure the queues are not full.

  6. Finally.... If your app and Web server are on separate machines then the MSMQs MUST be installed in domain mode (also called AD integration mode).  This is why BSI requires a domain account for the install and the machines must be members of a domain. If MSMQs are installed in domain mode then you will see a "public" group in addition to a "private" group. You will also see the security tab when you go under properties, but may not be able to go to it if they are not in domain mode. This is REQUIRED if the app and web are separate boxes or else Microsoft does not allow remote connections.

 

Environment

Release: GATBIL05900-8.3-Business Service Insight-Business Intelligence Layer-(RDL)
Component: