MQ_error_service_not_available
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MQ_error_service_not_available

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Article ID: 40582

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Updated On:

Products

CA Business Service Insight

Issue/Introduction

Following error is seen in the BSI T_LOG table related to Adapters:

T_APPLICATION_GROUPS, Communication error: Problem performing operation on queue.

Queue: "OG Adapter Listener"

Operation: "Open Queue"

Addicional error information:

Friendly Name: MQ_ERROR_SERVICE_NOT_AVAILABLE

Environment

CA Business Service Insight 8.3.x and 9.x

Multi-tier installation

Cause

Most common cause is that Message Queuing cannot find the correct queue in the BSI environment. Such queues include public queues not registered in the directory service and Internet queues that do not exist in the MSMQ namespace.

This error is also returned when the user does not have sufficient permissions to perform the operation.

Resolution

When a BSI Adapter is stopped or started, this places a message in the Adapter listener queue. This is an MSMQ on the BSI APP server. The Adapter listener service then picks up this message and takes the appropriate action. 

Perform the following troubleshooting:

1. Via the BSI UI, navigate to Administration->Site settings->Advanced.

2.  Click on the group called "Queues". Make sure that the three Queue settings all point to the BSI APP server

3.  Via the BSI Web server, ensure that you can resolve and ping the BSI APP server hostname.

3.  On the BSI APP server, open MSMQs (under Server Manager and Features) and open private queues. Make sure you can see all four of the BSI queues.

4.  Right-click on each of the four queues and go under the Security tab. Be sure that the user account the BSI services run under and the BSI IIS website runs under has full rights to the queues.

5.  Click on the private queue group and look at the message counts for each of the queues on the right and check that the queues are not full.

6.  If the BSI APP and Web servers are on separate machines (recommended) then the MSMQs MUST be installed in domain mode (also called AD integration mode).  This is why BSI requires a domain account for the install and the machines must be members of a domain. If MSMQs are installed in domain mode then you will see a "public" group in addition to a "private" group. You will also see the security tab when you go under properties, but may not be able to go to it if they are not in domain mode. This is REQUIRED if the BSI APP and Web servers are on separate servers or else Microsoft does not allow remote connections.

Additional Information

Refer to KB article All about logging and debug for Business Service Insight for information on logging within CA Business Service Insight