Editing or remediating a host profile generates error: A general system error occurred: "Host profile update failed. Check the log files for details."
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Editing or remediating a host profile generates error: A general system error occurred: "Host profile update failed. Check the log files for details."

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Article ID: 405808

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Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

Unable to edit/update host profile and seeing a "generic failure occurred" error due to this host not able to scan for compliance.

Environment

vSphere 8.0U3

Cause

The caused of the issue is a corrupt host profile applied to the hosts in the cluster.

Resolution

Note: Please ensure that you have taken a backup of your vCenter as per article:
Overview of Backup and Restore Options in vCenter Server 6.x/7.0.x/8.0.Follow the steps below to resolve the issue

  1. Detach the host profile from the ESXi hosts/cluster.
  2. Changed the settings on the server to match the settings required in the host profile.
  3. Extracted a new profile from the ESXi host.
  4. Edited the new host profile to exclude the Storage Configuration and Device Alias Configuration settings - Save the profile.
  5. Attached the host profile to the ESXi hosts/Cluster.
  6. Scan and remediate the ESXi hosts. (Maintenance mode)

For further information regarding attaching/detaching/remediating ESXi hosts using host profiles, please reference the following document:
How Do You Manage vSphere Host Profiles in the vSphere Client