System Overview Dashboard fails to load with an error "Failed to get report - A data-source execution error for a report"
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System Overview Dashboard fails to load with an error "Failed to get report - A data-source execution error for a report"

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Article ID: 405799

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Updated On:

Products

VMware NSX

Issue/Introduction

The NSX System Overview Dashboards error out and do not display any data.

The error illustrated in the UI is similar to "Failed to get report - A data-source execution error for a report".

See below example of errors:

It is observed in /var/log/proton/nsxapi.log that there is "java.net.SocketTimeoutException" exception while getting data from url http://127.0.0.1:7440/nsxapi/api/v1/ui-controller/nodes-count-info.

<DATE_TIME>  INFO http-nio-127.0.0.1-7440-exec-38475 RESTDatasourceConfiguration 76723 SYSTEM [nsx@6876 comp="nsx-manager" level="INFO" reqId="<ID>" subcomp="manager" username="admin"] getting data from url http://127.0.0.1:7440/nsxapi/api/v1/ui-controller/nodes-count-info

<DATE_TIME> ERROR http-nio-127.0.0.1-7440-exec-38645 HTTPSClient 76723 SYSTEM [nsx@6876 comp="nsx-manager" errorCode="MP193072" level="ERROR" reqId="<ID>" subcomp="manager" username="admin"] Error detected while invoking the rest api through httpclient
java.net.SocketTimeoutException: Read timed out

It is also seen in /var/log/proton/localhost_access_log.txt that "GET /nsxapi/api/v1/ui-controller/nodes-count-info" is taking too long to fetch the response.

<DATE_TIME> - "GET /nsxapi/api/v1/ui-controller/nodes-count-info HTTP/1.1" 200 711 10758543 10758455 X

 

Environment

VMware NSX

Cause

The issue is caused by the GET /nsxapi/api/v1/ui-controller/nodes-count-info call taking too long to complete.

Resolution

To workaround this issue, restart the proton service on the problematic NSX Manager.

1.  Connect to the one NSX Manager in root mode.

2.  Run the following command to restart proton:

#/etc/init.d/proton restart

 

If the workaround doesn't work, please contact Broadcom Technical Support for assistance.

See Creating and managing Broadcom support cases for details on opening a case.