CA Performance Centre (CAPC) Upgrade Failure
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CA Performance Centre (CAPC) Upgrade Failure

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Article ID: 40572

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Updated On:

Products

CA Infrastructure Management CA Performance Management - Usage and Administration

Issue/Introduction

Upgrading CAPC fails due to the following error:

Custom Action: com.ca.im.installanywhere.action.MigrateDb 

Status: FATAL ERROR 

Additional Notes: FATAL ERROR - class com.ca.im.installanywhere.action.MigrateDb FatalInstallException: DbMigrate threw an exception. caught exception in processManifest. Message: Error executing command: INSERT INTO context_map_i18n (ContextName,Title,CultureID) VALUES ('tcpstats','à Mobile Wireless TCP Stats è02+7','it-IT'),('tcpstats','Mobile Wireless TCP Stats','en-US'),('tcpstats','???? TCP ????','zh-TW'),('tcpstats','? Mobile Wireless TCP Stats ?02+7','ko-KR'),('tcpstats','Statistiques TCP sans fil mobile','fr-FR'),('tcpstats','Mobile Wireless TCP ??','zh-CN'),('tcpstats','???? & ????? TCP ??','ja-JP') 


Duplicate entry 'tcpstats-en-US' for key 'PRIMARY'

Environment

CAPC all releases

Cause

tcpstats are in the context_map with a NULL Package value

 

Resolution

The following should be done to resolve this issue on the CAPC server:

  1. cd /opt/CA/MySql/bin

  2. Run:

    ./mysql netqosportal -e "delete from context_map where contextname = 'tcpstats';"
     

  3. Run:

    ./mysql netqosportal -e "delete from context_map_i18n where contextname = 'tcpstats';" 

  4. Then run the upgrade again