Health monitor gets removed from Load Balancer while saving pool from Cloud Director
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Health monitor gets removed from Load Balancer while saving pool from Cloud Director

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Article ID: 405708

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Updated On:

Products

VMware Cloud Director

Issue/Introduction

On Cloud Director 10.x, if you edit and save the Load balancer pool as below without any changes, health monitor gets removed.

Steps to identify the problem:

  1. Navigate to Org VDC
  2. Go to "All Org VDC Edge Gateways"
  3. Click on Pools
  4. Select the Load Balancer pool that you wish to edit
  5. Click on Save without any edits
  6. Check on NSX manager if health monitor information persists/gets removed.

Environment

Cloud Director 10.x

Cause

This happens as per the current product behavior where the health monitor information is not returned while saving pool.

Resolution

Broadcom Engineering is aware of this behavior and is working towards a fix.

Workaround:

Disable and re-enable health monitor on the pool.

Steps:

  1. Login to the Provider portal
  2. Select the affected organization
  3. Go to Load Balancer -> Pools
  4. Select the affected pool
  5. Click on "Assign Health monitor"

Reference documentation: Create and assign a custom health monitor

For any further queries, please reach Broadcom Technical Support via a support request. Refer : Creating and managing Broadcom support cases