Autoschedule pushes the task start & finish date to 2079
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Autoschedule pushes the task start & finish date to 2079

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Article ID: 405613

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Updated On:

Products

Clarity PPM SaaS Clarity PPM On Premise

Issue/Introduction

When using autoschedule on a project, the task date is changed to 6/2/2079.  This happens in MUX and Classic

Steps to Reproduce: 

  1. Create a new project
  2. Create a task with fixed duration
  3. Add a resource to the team with Default Allocation set to zero
  4. Assign the resource to the task
  5. Enter 10 for the ETC
  6. Go to the Task Timeline view
  7. Click Actions>>Auto Schedule
  8. Click AutoSchedule

Expected Results: The task will be autoscheduled correctly, dependent on the start date

Actual Results: The task start and finish date changed to 6/2/79

Environment

Clarity 16.3.0, 16.3.1, 16.3.3

Cause

Investigated in DE173848

Resolution

When a Staff Member does not have any capacity due to zero allocations, the auto-scheduler cannot determine the next available date to schedule a task with an ETC amount.  It will keep trying to find a future date where the resource has allocations for the project, and it will keep going until it hits the internal system limit date of June 2, 2079. 

If you would like to use auto-schedule, you will need to provide non-zero allocations or 'Lock' the Task.

If the Task is 'locked', it will NOT move when using auto-schedule.

Additional Information

This is caused if the task is set to fixed duration, the resource allocation is zero, and the resource has ETCs.

Workaround

Either remove the fixed duration tag or put a value in the allocation.