Unable to save reports to a shared external location
search cancel

Unable to save reports to a shared external location

book

Article ID: 405573

calendar_today

Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

  • The schedule of a report has been configured to save the generated report to an external location.
  • When configuring the "Schedule Report", the path to a sub folder of the Network Share Root folder location has been added to "Relative Path".
  • After deleting the root path to the shared location from "Relative Path" when configuring the "Schedule Report", the report is not saved as expected.
  • The Network Share Plug-In for VMware Aria Operations Reports has been created as per documentation Adding Outbound Notification Plug-Ins in VMware Aria Operations
  • The user configured in the Outbound Setting has read, write, and delete permissions to the network share location.

Environment

VMware Aria Operations 8.18.x

Cause

This is a known issue when configuring Schedule Report to save the reports to a sub folder of the Network Share Root folder location configured in the Network Share Plugin.

Resolution

Workaround

OPTION 1

Delete and recreate the Schedule Report leaving the "Relative Path" empty so the reports will be saved to the Network Share Root folder location configured in the Outbound Settings . For additional information visit the documentation Schedule a Report

OPTION 2

  1. Editing the Network Share Plugin in the Outbound Settings to have as Network Share Root folder a new path to the created subfolder. For additional information visit the documentation Add a Network Share Plug-In for VMware Aria Operations Reports
  2. Delete and recreate the Schedule Report leaving the "Relative Path" empty so the reports will be saved to the Network Share Root folder location configured in the Outbound Settings . For additional information visit the documentation Schedule a Report