ESXi shutdown hung at "Reboot_RunHandlersVsan" after upgrading
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ESXi shutdown hung at "Reboot_RunHandlersVsan" after upgrading

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Article ID: 405500

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Updated On:

Products

VMware vSAN

Issue/Introduction

During rebooting after upgrading or patching ESXi to 8.0.x, ESXi shutdown hung at "Reboot_RunHandlersVsan".


vSAN vmk's uplink belongs to LAG.

Environment

ESXi 8.0.x

Cause

ESX host reboot stops due to indefinite delay in the shutdown of the vSAN cluster monitoring, membership, and directory service (CMMDS)
When rebooting an ESX host, network conditions can cause the vSAN CMMDS shutdown process to delay indefinitely.

Resolution

Workaround:

  • If you already meet this issue, please try power Off and power on Server.
  • To avoid this issue,try the following:
1. Put one host in maintenance mode with ensure accessibility.
2. Store output of `esxcli vsan network list >> network_list` to a file in persistent storage. We mainly need vmknic name.  
3. Clear vsan network configuration by running `esxcli vsan network clear`. This host will partition from the vSAN cluster after this step.  
4. Reboot host  
5. Wait for host to be rebooted  
6. Add all vmknics from network_list stored in step 2. to vSAN network configuration `esxcli vsan network ip add -i <interface-name>`  
7. Wait for health to be green.  
8. remove network_list file created in 2.  
9. Proceed to the next host
 

This issue will be fixed in future release.

Additional Information

If your vSAN vmk is not using LAG, Please trigger NMI (check Using hardware NMI facilities to troubleshoot unresponsive hosts) and collect support bundle and contact VMware support.