Understanding Password Management Scope for VMware Cloud Foundation Components in 9.0
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Understanding Password Management Scope for VMware Cloud Foundation Components in 9.0

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Article ID: 405467

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Updated On:

Products

VMware Cloud Foundation

Issue/Introduction

  • The VCF Operations UI currently does not have the functionality to update or remediate SSO and Service accounts while the capability is available within both the SDDC Manager and vCenter UIs
  • Managing SSO and Service Account passwords is facilitated by accessing password management capabilities within the individual SDDC Manager and vCenter UIs



Environment

VMware Cloud Foundation 9.x

Cause

The VCF Operations Console password management documentation has ambiguity. The current statement that it manages all component passwords is not valid.

Reference:  "You can use the VCF Operations console to update and remediate the passwords for all VMware Cloud Foundation components."
https://techdocs.broadcom.com/us/en/vmware-cis/vcf/vcf-9-0-and-later/9-0/fleet-management/manage-passwords.html

We must clarify which passwords VCF Ops handles versus those requiring SDDC Manager or vCenter UI, to prevent confusion.


 

Resolution

Currently Broadcom Product/Engineering is working on updating the Techdocs link 

VCF Ops 9.0 UI cannot manage updating/remediate of:

  • PSC(SSO) password
  • vCenter service accounts
  • NSX-T service accounts


You may have to access password management option in SDDC manager UI/vCenter UI