Unable to save ticket with error "One or more properties require values".

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Article ID: 40545

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Updated On:

Products

CA Service Management - Service Desk Manager CA Service Desk Manager

Issue/Introduction

After changing request area in a request/incident, click save. User will get this error "ADH05807: One or more properties require values". All the properties have been filled so the error doesn't seem to be valid.

Usually, the message states which properties name and highlight the empty field. This error does not show the field.

 

Cause

"keep task" option is installed. "delete_null_properties" option is not installed. 

Out of box a request area can have max 23 properties.  With the above options settings the error message, "ADH05807: One or more properties require values" would display when request area is changed and it has more than 23 properties. 

Eg. the original request area had 15 properties in the request. Change the request area with 10 properties, total properties add up together 25 which exceed the max 23. The page could display up to 23 properties only.  

You can read more about the option "delete_null_properties" at 

https://docops.ca.com/ca-service-management/14-1/en/administering/administering-ca-service-desk-manager/options-manager

Environment

Release: 14.1, 17.x
Component: USRD

Resolution

Workaround:

Either install "delete_null_properties" option or increase the 23 properties limit by customizing the pages: load_properties.htmpl and xx_prop_tab.htmpl.

Additional Information

How to add additional properties to the Service Desk Form listings for Incidents and Requests. 

Attachments

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