Triggered Alarm: The virtual machine was reset by vSphere HA. Depending on how vSphere HA is configured, this condition can occur because the VMware Tools heartbeat or the application heartbeat status turned red.
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Triggered Alarm: The virtual machine was reset by vSphere HA. Depending on how vSphere HA is configured, this condition can occur because the VMware Tools heartbeat or the application heartbeat status turned red.

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Article ID: 405399

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

Virtual machine unresponsive with the following alarm triggered for it:

 

Description:

VM_NAME on ESXI-NAME in cluster CLUSTER_NAME in DATACENTER_NAME reset by vSphere HA. Reason: VMware Tools heartbeat failure. A screenshot is saved at [DATASTORE_NAME] VM_DIRECTORY/VM_NAME-1.png.

Event Type Description:

The virtual machine was reset by vSphere HA. Depending on how vSphere HA is configured, this condition can occur because the VMware Tools heartbeat or the application heartbeat status turned red. The event contains the location of the screenshot taken of the guest console before it was reset. You can use this information to determine the cause of the heartbeat failure.

Possible Causes:

  • The VMware Tools heartbeat turned red. This condition can occur if the operating system failed with a blue screen or becomes unresponsive. It also can occur because VMware Tools failed or was shut down. Action: Check the screenshot image to see if the cause was a guest operating system failure. If the virtual machine is reset frequently, check for a persistent problem with the operating system that requires attention. Consider configuring the cluster so that vSphere HA waits for a longer period after heartbeats are lost before taking action. Specifying a longer period helps avoid triggering resets for transient problems. You can force a longer period by decreasing the "monitoring sensitivity" in the VM Monitoring section of the Edit Cluster wizard.
  • The application heartbeat turned red. This condition can occur if the application that is configured to send heartbeats failed or became unresponsive. Action: Determine if the application stopped sending heartbeats because of a configuration error and remediate the problem.

 

 

 

Environment

vCenter Server Appliance 8.0.x

ESXi hosts 8.0.x

Cause

The alarm indicates that the VMware Tools application running inside the guest OS VM is affected not the cause, then the vSphere HA triggered the reset action to recover the virtual machine since it has been detected as unresponsive, not that vSphere HA caused the VM to be unresponsive.

 

Resolution

Third Party guest operating system issue caused the VMware Tools to be unresponsive, hence an investigation from guest OS vendor must be performed to identify the causes why the guest operating system became unresponsive or why the VMware Tools application stopped to be responsive inside of the guest OS.

Additional Information

The investigation from the guest OS vendor, may return failures on accessing the virtual hardware, hence for the root cause of the issue additional investigation may be required on the ESXi level according to the findings on the guest OS level.