Excessive vmkernel.log Growth Due to Unmap and Volume Closure Messages.
search cancel

Excessive vmkernel.log Growth Due to Unmap and Volume Closure Messages.

book

Article ID: 405398

calendar_today

Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

  • On ESXi 8.x hosts, the /var/log/vmkernel.log file may grow rapidly and rotate frequently due to repeated informational log messages related to: 
    • Unmap operations on VMFS datastores.
    • Failed cleanup of SCSI registration keys during NVMe volume closure.

Sample /var/log/vmkernel.log entries:

2025-06-22T13:57:03.600Z In(182) vmkernel: cpu96:2102445)Unmap6: 10536: datastore1 (55): Acquired UC with 0 OP ucOffset 458752 ucIndex: 97
2025-06-22T13:57:03.600Z In(182) vmkernel: cpu96:2102445)Unmap6: 10568: datastore1 (55): Unmap capability 0 OP i: 0 offset: 65536 endROffset: 589824 Acquired: TRUE

2025-06-22T13:56:06.870Z In(182) vmkernel: cpu16:4927072)Unmap6: 10536: datastore2: Acquired UC with 0 OP ucOffset 229376 ucIndex: 41
2025-06-22T13:56:06.870Z In(182) vmkernel: cpu16:4927072)Unmap6: 10568: datastore2: Unmap capability 0 OP i: 0 offset: 65536 endROffset: 589824 Acquired: TRUE

Volume closure warnings: /var/log/vmkwarning.log

2025-07-27T09:46:08.792Z Wa(180) vmkwarning: cpu57:2098009)WARNING: HBX: 2723: Failed to cleanup registration key on volume675f0dc7-########-####-d404e6e3dbe0: Failure
2025-07-27T09:46:08.793Z Wa(180) vmkwarning: cpu57:2098009)WARNING: Vol3: 4678: Error closing the volume: . Eviction fails: Failure

Environment

VMware ESXi 8.x

Cause

The volume volume675f0dc7-########-####-d404e6e3dbe0 is being reopened frequently, triggering repeated volume closure operations. During each closure:

  • The system attempts to remove the SCSI reservation key using the FS3_CleanupDistributedLocking function.

  • Due to a known issue in the Pluggable Storage Architecture (PSA), reservation state in "set" mode is not properly tracked.

  • As a result, cleanup of the registration key fails.

These repeated failures lead to warning messages being continuously logged in the /var/log/vmkernel.log file.

Resolution

This issue is resolved in VMware ESXi 8.0 Update 3e (Build 8.0 P05).

Action: Upgrade affected hosts to ESXi 8.0 U3e or later to prevent further excessive logging caused by PSA cleanup behavior.

Additional Information

Impact/Risk

  • No functional impact to workloads is expected.
  • Operational Impact: High log volume can lead to:
    • Rapid log rotation
    • Increased disk usage in /var partition
    • Difficulty in isolating other events in logs during troubleshooting