Log Extract not processing to full date range.

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Article ID: 40536

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Updated On:

Products

CA-24X7 High-Availability Manager for DB2 for z/OS CA-Batch Processor Compile QQF CA Data Compressor for DB2 for z/OS Data Navigator for DB2 UDB for z/OS CA-DB Delivery for DB2 CA Unicenter NSM CA Log Compress DBA for DB2 Guide Online CA InfoRefiner Advantage InfoRefiner Advantage InfoRefiner Maint Upgrade CA InfoTransport Advantage InfoTransport Maint Upgrade Online Reorg for DB2 for z/OS CA RC/Update for DB2 for z/OS Query Analyzer RI Editor for DB2 for z/OS DB2 TOOLS- DATABASE MISC

Issue/Introduction

Problem:
CA Log analyser for DB2 for z/OS (PLA) will process for a while before stopping suddenly. It appears to only process a maximum of 4 days of Log data.
The extract hadn’t been run for 7 days, the first run processed 4 days of the Log, then next run did the rest.
It normally picks up from where it left off and processes to the end of the log.
Why did it stop at 4 days?


Cause:
User was using RESUME Control Statement = 96.
RESUME   = (96)


Resolution:
The use of option RESUME = (96) tells PLA to process 96 hours of log data and then set the resume point for the strategy.
A maximum of 3 digits (999 hours) are allowed to be used on the card, so the maximum is about 41 days.
If the amount exceeds the amount of time from the RESUME point then PLA will read until the end of the log and then stop processing.

Environment

Release:
Component: PLA