VIP Enterprise Gateway RADIUS Validation Server Logs Not Showing Correct NAS/Framed IP Address
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Article ID: 405293
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Updated On:
Products
VIP Service
Issue/Introduction
After enabling source IP address logging for the NAS or Framed IP address of the RADIUS client on a validation server the IP address captured in the logs may stay the same for subsequent user authentication requests.
Environment
VIP Enterprise Gateway 9.11.1
OS: Windows Server
Cause
This is caused by a known issue where the memory block used to store these attributes may not be cleared properly when another user authenticates via RADIUS.
Resolution
This issue will be formally addressed in the upcoming VIP Enterprise Gateway 9.11.2 later this year. In the meantime, a hotfix is available to resolve this issue.
Note: This hotfix should be applied only on VIP EGW 9.11.1 for Windows.
To apply the hotfix, please follow the steps below.
Download VIP_EG_9_11_1_Windows_BRCMVIP-8220_HotFix.zip and extract the contents to a temporary location (for example, C:/temp).
Stop all validation servers from the EG Console.
Make a backup of the following file: <VRSN_MAUTH_HOME>/Validation/bin/VSValidationServer.exe
From the temporary location where the download was extracted copy the following files. Copy VIP_EG_9_11_1_Windows_BRCMVIP-8220_HotFix/Validation/bin/VSValidationServer.exe to the <VRSN_MAUTH_HOME>/Validation/bin
Start all validation servers.
Rolling back the hotfix
If you encounter any issues after installing this hotfix, use the following steps to revert the changes.
Stop all validation servers.
Navigate to the location where you backed up the VIP Enterprise Gateway files during installation of the hotfix and copy the backed up files to their original location. Copy VSValidationServer.exe to <VRSN_MAUTH_HOME>/Validation/bin