"Failed to install software on host. Pushing NSX depot(s) on Compute Manager: UUID failed with error" is displayed while preparing vLCM enabled cluster for NSX
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"Failed to install software on host. Pushing NSX depot(s) on Compute Manager: UUID failed with error" is displayed while preparing vLCM enabled cluster for NSX

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Article ID: 405258

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Updated On:

Products

VMware NSX

Issue/Introduction

  • The required ports are opened between vCenter and the NSX manager as mentioned in VMware Ports and Protocols, this can be verified by running the following command, as the root user on the vCenter Server: nc -zv <nsxmgr-IP/FQDN> 443.
  • The Compute Manager and the NSX manager may be on different physical sites.
  • From vCenter ping latency to the NSX manager is high, e.g., 150ms. 
  • In the vCenter log /var/log/vmware/envoy/envoy-access.log, we can see the following entries:
    info envoy[51210] [Originator@6876 sub=Default] <date/time> POST /vum-fileupload/upload/ 0 http2.remote_reset - 69500888 0 - 299361 - - <NSX Manager IP> HTTP/2 TLSv1.2 <vCenter IP>:9087 127.0.0.1:38396 HTTP/1.1 - 127.0.0.1:9085 -
  • Preparation of ESXi hosts in a vLCM enabled cluster fails with the error on the NSX UI:
    Failed to install software on host. Pushing NSX depot(s) on Compute Manager: <transport node UUID> failed with error:Error while logging into VCcom.vmware.nsx.management.ovfops.exception.CommandExecutionFailed: % Received % Xferd Average Speed Time Time Time Current

    Dload Upload Total Spent Left Speed
     
    0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0
    0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0
    0 173M 0 0 0 65536 0 55507 0:54:38 0:00:01 0:54:37 55491
    0 173M 0 0 0 320k 0 138k 0:21:23 0:00:02 0:21:21 138k
    ******************************************************
    27 173M 0 0 27 48.0M 0 164k 0:18:03 0:04:59 0:13:04 157k
    curl: (28) Operation timed out after 300000 milliseconds with 0 bytes received

Environment

VMware NSX

Cause

The connection between vCenter (vLCM) and NSX manager, when downloading the VIBs, has a timeout of 5 minutes, therefore if the operation is unable to complete within this time, the above error is displayed.

Resolution

Resolve the latency issue between the NSX manager and the Compute Manager.

Additional Information

If this KB did not help resolve your issue, you can review the following KB for further troubleshooting steps:  Troubleshooting NSX Installation Operations