Deployment fails with "Failed to Reserve IP for ..."
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Deployment fails with "Failed to Reserve IP for ..."

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Article ID: 405251

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Updated On:

Products

VMware Tanzu Platform - Cloud Foundry

Issue/Introduction

When creating or updating a deployment, (as part of an Apply Changes to deploy a Tile or even as part of "upgrade all service instances" errand), you can see following error during the task execution: 

 

Using environment '###.###.###.###' as client 'ops_manager'

Task ######

Task ###### | 10:25:34 | Preparing deployment: Preparing deployment (00:00:01)
                        L Error: Failed to reserve IP for 'rabbitmq-server/########-####-####-####-######## (0)' for manual network 'examplenetwork': no more available
Task ###### | 10:25:35 | Error: Failed to reserve IP for 'rabbitmq-server/########-####-####-####-######## (0)' for manual network 'examplenetwork': no more available

Task ###### Started  Mon Jul 14 10:25:34 UTC 2025
Task ###### Finished Mon Jul 14 10:25:35 UTC 2025
Task ###### Duration 00:00:01
Task ###### error

Capturing task '######' output:
  Expected task '######' to succeed but state is 'error'

Exit code 1

Environment

All versions.

Cause

The message you are seeing " Failed to reserve IP" means that all the IP's that are available to bosh are in use and there is no one free.

Resolution

Go to Bosh director Tile -> Create Network -> Reserved IP Ranges and see if there is a chance to reduce the "Reserved IP Ranges". Tanzu Operations Manager does not deploy VMs to any address in this range and reducing the range will increase the number of available IP's.

If you can't reduce that range, add another subnet to increase the number of available IP's. See Expanding your network with additional subnets.