Error "An Unexpected error has occurred" message appears accessing vSphere Lifecycle Manager and baselines from the ESXi host.
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Error "An Unexpected error has occurred" message appears accessing vSphere Lifecycle Manager and baselines from the ESXi host.

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Article ID: 405178

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Updated On:

Products

VMware vSphere ESX 8.x VMware vSphere ESX 7.x

Issue/Introduction

  • Lifecycle Manager is not accessible in the vSphere client and accessing it will show the following error message:

"An unexpected error has occurred" or
"You have no privileges to view this object or it does not exist".

  • Accessing baselines from the ESXi host will show the following error message:

"An unexpected error has occurred"

  • In `/var/log/vmware/vsphere-ui/logs/vsphere_client_virgo.log` will show the following information:

 [WARN ] p-nio-127.0.0.1-5090-exec-17 com.vmware.vum.client.remoting.impl.VumServiceImpl Request failed com.vmware.vim.vmomi.client.exception.ConnectionException: https://<vcenter fqdn>:8084/vci/sdk invocation failed with "java.net.SocketTimeoutException: Read timed out"

at com.vmware.vim.vmomi.client.common.impl.ResponseImpl

[WARN ] p-nio-127.0.0.1-5090-exec-17 com.vmware.vum.client.remoting.impl.VumServiceImpl Request failed com.vmware.vim.vmomi.client.exception.ConnectionException: https://<vcenter fqdn>:8084/vci/sdk invocation failed with "java.net.SocketTimeoutException: Read timed out" 

Environment

  • VMware vCenter Server 7.0
  • VMware vCenter Server 8.0

Cause

  • This error is caused because the vSphere Lifecycle Manager service running on port 8084 inside vCenter did not respond within the expected time, resulting in a socket timeout. The underlying reason is usually hung, overloaded, or slow LCM backend service, which prevents the UI from retrieving data and leads the generic " An unexpected error has occurred"

Resolution

Option 1:  Using vCenter Server Management :
       For VMware vCenter Server Lifecycle Manager:

    • Login to vCenter Server Management using https://<vcenter fqdn>:5480
    • Click on the  services 
    • Select VMware vCenter Server Lifecycle Manager service 
    • Click on Restart 

      For VMware vSphere Update Manager service :

    • Select VMware vSphere Update Manager service 
    • Click on Restart

 

Option 2: Using command-line from vCenter Server

  • Log in to the vCenter Server Appliance through SSH.
  • Stop and Start the Update Manager service:
    • service-control --stop vmware-updatemgr && service-control --start vmware-updatemgr
  • Stop and Start the VLCM service in vCenter Server:
    • service-control --stop vlcm && service-control --start vlcm
  •