Is CA Compress for IMS backward-compatible?

book

Article ID: 40514

calendar_today

Updated On:

Products

CA Database Analyzer (IMS Tools) CA Mainframe Configuration Manager for IMS for z/OS IMS TOOLS - MISC CA Compress Data Compression (IMS Tools) CA Database Analyzer for IMS for z/OS CA Database Copier for IMS for z/OS CA Database Organizer for IMS for z/OS CA Mainframe Extended Terminal Manager (IMS Tools) CA High Performance Recovery for IMS for z/OS CA Database Organizer (IMS Tools) CA Mainframe Program Restart Manager for IMS for z/OS CA Secondary Index Builder for IMS for z/OS CA Secondary Index for IMS for z/OS

Issue/Introduction

Question:

Is CA Compress for IMS backward-compatible. Can we use the same FDTLIB, GENLIB and Control File from an earlier release?

 

Answer:

Yes CA Compress for IMS is backward-compatible and therefore there is very little customization to perform when upgrading.

1. If you customized the $ITK clist for the earlier release then you will need to customize it for the new release. This is required if you use the ISPF Interactive Dialog.

2. The FDTLIB, GENLIB and Control File are all backward-compatible, and so no action needed. However, you will need to modify the SHRISPF member in the new CIMTPARM library to specify your existing CONTROL, FDTLIB and GENLIB data set names.

 

Further Information:

The documentation for customizing the ISPF Interface can be found at https://docops.ca.com/ca-database-management-solutions-for-ims-for-z-os/18-0/en/installing-and-configuring/configuring-ca-database-management-solutions-for-ims/implementing-the-ispf-interface

Environment

Release:
Component: CMPIMS