Encountering error "Unable to determine the agent version" while upgrading the Autosys Agent
search cancel

Encountering error "Unable to determine the agent version" while upgrading the Autosys Agent

book

Article ID: 405135

calendar_today

Updated On:

Products

Autosys Workload Automation

Issue/Introduction

Upgrading Agent from 11.3 to R24.0 throws error:

===============================================================================
Agent Path
----------

Enter the install folder of the WA Agent to be upgraded.


  Default Install Folder: /opt/CA/WA_Agent

ENTER AN ABSOLUTE PATH, OR PRESS <ENTER> TO ACCEPT THE DEFAULT
      : /opt/CA/WorkloadAutomationAE/SystemAgent/WA_AGENT

INSTALL FOLDER IS: /opt/CA/WorkloadAutomationAE/SystemAgent/WA_AGENT
   IS THIS CORRECT? (Y/N): Y

 

===============================================================================
Agent Upgrade Error
-------------------

Unable to determine the agent version.

Environment

Upgrade from Agent version R11.3 to R24.0 

OS: HP-UX B.11.31

Cause

As R11.3 is very old version, it's failing to determine the correct version, service pack level, and build number.

Resolution

To resolve this and allow the upgrade to proceed, follow the below steps:
1. Rename current cybAgent.bin under Agent installation path to cybAgent.bin.org

2. Create a file named cybAgent.bin with the following content:
======
echo CA Workload Automation Agent
echo "   for LINUX (Intel) 64-bit"
echo "Version R11.3, Service Pack 1, Maintenance Level 0, Build 353"

echo "Enabled plug-in(s):"
echo "- runner"
======

3. Grant execute permission (chmod 755) to the new cybAgent.bin file  

4. Once the above steps are completed, proceed with the upgrade.