Enabled interfaces in CA Performance Management (CAPM) stop being polled
search cancel

Enabled interfaces in CA Performance Management (CAPM) stop being polled

book

Article ID: 405120

calendar_today

Updated On:

Products

Network Observability CA Performance Management

Issue/Introduction

Some interfaces stop polling and show no data with the following errors being repeatedly generated in the pollErrors.log generated by dcdebug:

Jan 14 01:17:30.001: POLLING_ERROR: , pollInterval=300000: errors for cycle 1736788200000 (Tue Jan 14 01:10:00 UTC 2025): [REQUEST_TIMED_OUT]

Environment

DX NetOps CAPM all currently supported releases

Cause

This can be due to several possible causes:

  1. MTU of server is lower than that of device so when packet size returned by device is relatively large, it fails to be received in the allocated time.

  2. The Timeout and/or Retries may be inadequate for the device.  

Resolution

For the possible causes listed above:

  1. To check the interface of the Data Collector (DC), on the DC command line, run:

    ifconfig| grep -i MTU

    This should return something similar to

    UP BROADCAST MULTICAST  MTU:1500  Metric:1
    UP LOOPBACK RUNNING  MTU:65536  Metric:1
    UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1

    The above shows the MTU to be a standard setting of 1500

    Then to check the device, you can run the following ping command:

    ping DEVICE_IP_ADDRESS -c 10 -M do -s 8972

    where:

    -M option tells ping to NOT fragment,
    -s sets the packet size,
    -c sets the number of pings to send.

    This will return something the device similar to:

    From test1.example.local (XXX.XXX.XXX.XXX) icmp_seq=1 Frag needed and DF set (mtu = 1500)
    From test1.example.local (XXX.XXX.XXX.XXX) icmp_seq=1 Frag needed and DF set (mtu = 1500)

    So you need to make sure both device and the DC have the same setting for MTU.


  2. By default, the maximum response time set is 9 seconds. Moreover, frequent SNMP time-out occurrence generates Data Aggregator polling stop event, as per:

    TechDocs : DX NetOps CAPM 24.3 : Polling Stopped Event Message

    If these errors or issues are the cause, then look to increase the Timeout and/or Retries parameter of the CA Performance Center SNMP Profile used for these items/devices.