Unable to Edit Rules in Filtered DFW Policies when using filters
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Unable to Edit Rules in Filtered DFW Policies when using filters

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Article ID: 405071

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Updated On:

Products

VMware vDefend Firewall VMware vDefend Firewall with Advanced Threat Prevention

Issue/Introduction

In the Security - Distributed Firewall in the NSX UI, you search for a specific Policy in the DFW.  After the policy is displayed, you try to perform any action on the rules (add, delete, etc) and the screen either returns to the full list of Policies or hangs until a page reload is performed.

Environment

vDefend Firewall 4.1.x 

Cause

If there are more than 1000 policies, and the filtered policy is in a position greater than 1000, then the cursor is set incorrectly in the API call causing the issue.

Resolution

The only work around is to not filter for the policy and to manually scroll down to the policy, then perform the action on the rules.

Fixed in vDefend Firewall 4.2.0 and above