Linux Agent Fails To Start With exit-code 127
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Linux Agent Fails To Start With exit-code 127

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Article ID: 405051

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Updated On:

Products

Carbon Black App Control

Issue/Introduction

  • When attempting to manually start the Linux Agent an error is returned similar to:
    /etc/init.d/b9daemon: line 389: daemon: command not found
    b9daemon.service: Control process exited, code=exited status=127
    b9daemon.service: Failed with result 'exit-code'
  • Checking the Agent service status, an error is returned similar to:
    ExecStop=/etc/init.d/b9daemon stop (code=exited, status=0/SUCCESS)
    ExecStart=/etc/init.d/b9daemon start (code=exited, status=127)

Environment

  • Red Hat Linux: All Supported Versions
  • Linux Agent: All Supported Versions

Cause

A required dependency, initscripts, is missing, misconfigured or otherwise corrupt.

Resolution

  1. Check PATH to be sure /sbin is included
    echo $PATH

    Example output:
    /home/USR/.local/bin:/home/USR/bin:/usr/local/bin:/usr/local/sbin:/usr/bin:/usr/sbin
  2. Verify initscripts is installed:
    dnf list installed initscripts
    1. If necessary, install initscripts using the command:
      sudo dnf install initscripts
    2. Refresh systemd to verify any changes take effect:
      sudo systemctl daemon-reload
    3. Attempt to start the Agent once more:
      sudo /opt/bit9/bin/b9cli --startup
  3. Verify the functions file exists in /etc/init.d
    ls -ltr /etc/init.d/
    • The functions file is added during install of initscripts.
    • If no functions file exists, reinstallation of initscripts or assistance from the OS vendor may be required to investigate further.
  4. Review systemd journal for errors relating to b9daemon
    sudo journalctl -xeu b9daemon.service
  5. Attempt to start the Agent without systemd
    sudo /opt/bit9/bin/b9daemon DAEMON
    1. Use b9cli to check the Agent status
      /opt/bit9/bin/b9cli --status
    2. If the Agent returns output, this indicates an issue with the systemd configuration on the endpoint and further assistance from the OS vendor may be required.
    3. If the Agent fails to start, uninstall the Agent and complete a new install.

Additional Information