Multiple Login prompts received, once authenticated to SAM / OI Domain Manager
search cancel

Multiple Login prompts received, once authenticated to SAM / OI Domain Manager

book

Article ID: 405024

calendar_today

Updated On:

Products

VMware Smart Assurance

Issue/Introduction

This article explains the steps to debug when multiple login prompts appear once the SAM or OI domain manager is authenticated successfully. 

This prompt appears to restore a saved connection instead pf default login prompt.

Environment

Smarts 10.1.X, 24.3.X

Cause

The topic Customizing Your Console talks about the functions and usage of Saved Consoles.

Saved Consoles configured to connect multiple domain managers can lead to multiple login prompts while attaching to respective SAM / OI domain. 
These domain are selected on the following example prompt:

Resolution

  • Check for the consoled configured in the Global Manager Admin Console → UserProfiles → Specific User Profile. 
    In this example we are viewing the default admin-profile:


  • Check the Saved Console Name and browse the same on the backend server at: <Base-Dir>/SAM/smarts/local/consoles/<user profille>
  • Check the <Console>.iccon file which is named same as the Saved Console highlighted above. 
  • Check for the Domain Manager (highlighted in orange) Configuration to attach to:
    Note: In this case we are working with the saved console of NotificaitonLog.iccon file
    V2.0
    com.smarts.viewer.console.SmConsoleSchema
    com.smarts.viewer.consolidation.SmConsNotificationsConsole

    InCharge Console
    <Details of Domain Manager #1> , <Details of Domain Manager #2> , <...etc these could be single or a comma separated list> 
    Notification Log Console

If the Domains listed in this configuration are not required, the user may chose to remove them from this configuration file accordingly.