"Users and Groups" tab not loading on SDDC manager when any of the domains is unreachable
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"Users and Groups" tab not loading on SDDC manager when any of the domains is unreachable

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Article ID: 404968

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Updated On:

Products

VMware Cloud Foundation

Issue/Introduction


1. Navigate to Single Sign On -> Users and Groups.
2. Click on '+ User or Group' button.
3. Select any domain from the dropdown menu.
4. If any of the domains are unreachable, no users or groups are listed for that domain which is expected behavior. However, if the selection for domain is changed, the page freezes with a loading indicator so no users/groups are listed for reachable domains as well.

Environment

VMware Cloud foundation 5.1 and 5.1.1

Cause

This issue occurs because when we make a selection for a domain, a single API is call made that fetches users and groups for all the domains and then based on selection, filtering is done on the client side.
If any of the domains are unreachable, the call gets stuck and no user/group for any domain is listed.

Resolution

The issue has been fixed in 5.2 where a separate call is made for each domain selection so that the users/groups for other domains which are reachable are shown. Also, if any of the domains is unreachable, instead of the page getting stuck, an error message is displayed.