Unable to fetch dataset or view joblog using ZOWE MVS and JES explorer
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Unable to fetch dataset or view joblog using ZOWE MVS and JES explorer

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Article ID: 404934

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Updated On:

Products

Zowe

Issue/Introduction

Use gateway port to login to desktop, then open JES/USS/MVS explorers. 
https://zowe.externalDomains[0]:zowe.externalPort/zlux/ui/v1/

Failed to access dataset using MVS Explorer, got Fetch Datasets failed for userID

Failed to view the status of a job using JES Explorer, got Unexpected token 'E', "Error 403:" ... is not valid JSON

 

Environment

ZOWE v2.18.1

Cause

ZOWE MVS explorer and JES explorer are ZOWE services that based on ZOSMF. 

User got the same 403 error using the "Job Output" in z/OSMF's web GUI. "HTTP-403 Forbidden" error usually indicating authentication failure.

Each TSO user ID that logs on to Zowe and uses Zowe services that use z/OSMF requires permission to access these z/OSMF services. It is necessary that every user ID be added to the group with the appropriate z/OSMF privileges, IZUUSER or IZUADMIN (default).

Resolution

Follow ZOWE document to Granting users permission to access z/OSMF

For example, if you use RACF, issue the following command to grant userid to access ZOSMF.

CONNECT (userid) GROUP(IZUUSER)