"can not delete the license as it is associated with one or more environments" error when removing license from lifecycle manager locker
search cancel

"can not delete the license as it is associated with one or more environments" error when removing license from lifecycle manager locker

book

Article ID: 404917

calendar_today

Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

  • Attempts to remove a license in Lifecycle manager locker component fail with:

"can not delete the license as it is associated with one or more environments"

  • The environment id referenced in the error message no longer exists and when you attempt to navigate to it you receive the error:

    "Environment with id <Uid> was not found. Go back to all environments."

Environment

Aria Suite Lifecycle 8.x

Cause

The issue can occur if there are stale entries in the 'vm_locker_reference' table which associates the license to a product that no longer exists

Resolution

If you experience this issue please contact support referencing this article 404917. For more information, see Creating and managing Broadcom support cases.