High pNIC error rate detected on ESXi host after upgrading ESXi host to version 8.0 u3
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High pNIC error rate detected on ESXi host after upgrading ESXi host to version 8.0 u3

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Article ID: 404857

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Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

  • On the UI hosts are reporting the error: "RX/TX Pause rate reaches <>% on vmnicX".
  • The values are mostly higher than 1000%: 3000%,2000%,5000%,etc.
  • The value of Receive packets dropped and TxXoff versus the packets counter does not indicate the percentage displayed or in a value to match the alarm.
  • There is no performance/latency issues reported on the VSAN. 
  • When using build ESXi 8.0.3 build-24585383 or higher.
 NIC statistics for vmnic1:
      Packets received: 3465641940
      Packets sent: 4147299144
      Bytes received: 6955624733129
      Bytes sent: 17914684133404
      Receive packets dropped: 13
      Transmit packets dropped: 0
      Multicast packets received: 15475950
      Broadcast packets received: 289350
      Multicast packets sent: 247061
      Broadcast packets sent: 12914
      Total receive errors: 0
      Receive length errors: 0
      Receive over errors: 0
      Receive CRC errors: 0
      Receive frame errors: 0
      Receive FIFO errors: 0
      Receive missed errors: 0
      Total transmit errors: 0
      Transmit aborted errors: 0
      Transmit carrier errors: 0
      Transmit FIFO errors: 0
      Transmit heartbeat errors: 0
      Transmit window errors: 0

Privstats:
      RxXon: 0
      RxXoff: 0
      TxXon: 15
      TxXoff: 64

Environment

vSphere ESXi 8.0.3
Vsphere 9

Cause

This is an incorrect reported alarm.

Resolution

Because the reported value exceeds 100%, the alarm cannot be remediated through normal thresholds. As a workaround, the alarm must be disabled.

Steps to disable the alarm from the vCenter UI:

  1. Select the affected ESXi host.

  2. Navigate to Configure → Alarm Definitions.

  3. Locate the alarm “High pNic error rate detected. Check the host's vSAN performance view for details.”

  4. Disable the alarm.

Permanent Fix:

This issue has been resolved in vSphere ESXi 8.0.3.0 Patch 07 (Build 25067014).

The fix addresses an issue where vSAN network alarm incorrectly reports network error rates exceeding 100%.

Reference:
vSphere ESXi 8.0 U3h Release Notes
https://techdocs.broadcom.com/us/en/vmware-cis/vsphere/vsphere/8-0/release-notes/esxi-update-and-patch-release-notes/vsphere-esxi-80u3h-release-notes.html

vSphere 9: Future release

Additional Information