CNF reconfigure operation fails
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CNF reconfigure operation fails

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Article ID: 404775

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Updated On:

Products

VMware Telco Cloud Automation

Issue/Introduction

  • In TCA Manager UI Under Inventory > Network Function > Select Specific Network Function > Action > Reconfigure 
  • Reconfigure operation fails with error displayed in UI as below:
    "code":"E_INTERNAL_ERROR","message":"JSONObject[\"vduId\"] not found."

Environment

TCA 2.3.0 Build 22010335
Nokia CNF CHF-VOICE with volt-diagnostic:1.0.2

Cause

  • The issue is caused by the presence of a dot (.) character in the CNF name field, which is not permitted by the TCA database schema.
  • This is a known product limitation.

Resolution

Permanent resolution is available in TCA Software Release 3.3

Workaround:

Identify the corrupted entries in the DB and correct these entries in the DB.

  1. For the workaround implementation open a case with Broadcom Support 
  2. To prevent potential corruption during future CNF lifecycle or reconfiguration operations, ensure that dot (.) characters are not used in VDU names within the CSAR.