The Aria Operations Product UI and Admin UI are not accessible
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The Aria Operations Product UI and Admin UI are not accessible

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Article ID: 404755

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Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

  • Both the Product and Admin UI are available in a browser.
  • There is no authentication source in the product UI so login is not possible.
  • The Admin UI - Cluster Status page displays a warning the nodes are not accessible.
  • The take the cluster OFFLINE/ONLINE option is not visible or greyed out.

Environment

Aria Operations 8.x

Cause

  • There are many potential causes for this, and they are usually environmental:
    • CPU may have locked or read-only filesystems issues on a node due to storage or network outage.
    • Old snapshots - You should not keep Aria Operations running on snapshots for more than 72 hours, as this results in performance issues.
    • Disks might be full

Resolution

  1. As cluster cannot be taken Offline/Online in the UI we need to stop the services manually.
  2. Take snapshots of all the Aria Operations nodes before continuing with the remaining steps.
  3. Log in to Aria Operations console on all nodes as root using SSH, or console in vCenter.
  4. Stop the main service on all the nodes using the command:

    service vmware-vcops stop

  5. Ensure that the cluster status is set to Online-false by issuing the following command in all the nodes.

    sed -i -e 's/sliceonline = true/sliceonline = false/' /usr/lib/vmware-vcopssuite/utilities/sliceConfiguration/data/roleState.properties

  6. Once completed bring the cluster Online in the Admin UI.

Additional Information

There is a similar situation where when taking the cluster Offline in the Admin UI that the Aria Operations cluster failed to go offline