Managing environment with vCenter using the vSphere Client results in spinning wheel/wait cursors, very slow responses, and/or no responses.
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Managing environment with vCenter using the vSphere Client results in spinning wheel/wait cursors, very slow responses, and/or no responses.

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Article ID: 404712

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Updated On:

Products

VMware vSphere ESXi VMware vCenter Server VMware vCenter Server 8.0 VMware vCenter Server 6.0 VMware vSphere ESX 7.x VMware vSphere ESX 8.x VMware vSphere ESX 6.x VMware vSphere ESXi 8.0

Issue/Introduction

  • When trying to manage your environment with vCenter using the vSphere Client GUI, you experience extremely slow responses, such as spinning wheel("wait") cursors and screens populating very slowly or not at all. 
  • In the vmkernel.log on the host the vCenter server VM (VCSA) is running on, you see failing SCSI Commands similar to these:

2025-07-19T00:00:00.000Z cpu1:1234567)NMP: nmp_ThrottleLogForDevice:3867: cmd 0x28 (0xabcdef12345, 7654321) to dev (naa.XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX) on path vmhba2:C0:T0:L1 Failed: 
2025-07-19T00:00:00.000Z cpu1:1234567)NMP: nmp_ThrottleLogForDevice:3875: H:0x5 D:0x0 P:0x0 . Act:EVAL. cmdId.initiator=0xYYYYYYYYYYYY CmsSN -x2345678

 

and/or "state in doubt; " errors, such as: 

 

2025-07-19T00:00:00.000Z cpu1:1234567)WARNING: NMP: : nmp_DeviceRequestFastDeviceProbe:237: NMP device "naa.XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX" state in doubt; requested fast path state update...

 

NOTE: The exact SCSI command (cmd 0x28 in the above example) and Status code (H:0x5 D:0x0 P:0x0 in the above example) may vary depending on the specific operations in progress and the specific underlying issue. 

Environment

  • VMware vCenter (all versions)
  • VMware ESXi (all version)

Cause

  • This is due to external storage connectivity issue on the host that the vCenter VM (VCSA) is running on,  resulting in slow VM response due to the host waiting on the Storage I/O to complete. 

Resolution

Workaround: 

  • If the issue can be isolated to a specific host, please migrate the vCenter VM (VCSA) to a known good host that is not experiencing the issues (vMotion or cold migration).

 

Resolution:

 

Additional Information