SDDC Manager plan patching shows "No patches available" for VMware ESXi
search cancel

SDDC Manager plan patching shows "No patches available" for VMware ESXi

book

Article ID: 404682

calendar_today

Updated On:

Products

VMware SDDC Manager VMware Cloud Foundation

Issue/Introduction

It is observed, in SDDC Manager, the available update options for ESXi hosts are not being fetched, even when the environment is connected to the online depot with authentication tokens and capable of downloading patch bundles. 

SDDC Manager does not  list available updates under Plan patching, despite newer patch versions being available and displays the message "No patches available" .

The following error is logged in /var/log/vmware/vcf/lcm/lcm.log:

Got Http error[403] while downloading LCM 2.0 Manifest [/COMP/SDDC_MANAGER_VCF/lcm/productVersionCatalog/v1/lcmManifest.json]




Environment

VMware Cloud Foundation 5.x

Cause

The issue is caused by misconfigured or missing entries in the SDDC Manager configuration file /opt/vmware/vcf/lcm/lcm-app/conf/application-prod.properties, which results in failed access to the required LCM manifest.

Resolution

  1. SSH to the SDDC Manager VM with vcf user and su to root
  2. Back up the existing configuration file
    cp /opt/vmware/vcf/lcm/lcm-app/conf/application-prod.properties /opt/vmware/vcf/lcm/lcm-app/conf/application-prod.properties.bak
  3. Edit the configuration file using a text editor
    vi /opt/vmware/vcf/lcm/lcm-app/conf/application-prod.properties
  4. Update or add the following lines under LCM DEPOT PROPERTIES.
    lcm.depot.adapter.remote.lcmManifestDir=/COMP/SDDC_MANAGER_VCF/lcm/manifest
    lcm.depot.adapter.remote.lcmProductVersionCatalogDir=/COMP/SDDC_MANAGER_VCF/lcm/productVersionCatalog
  5. Restart the LCM service
    systemctl restart lcm
  6. Re-check the SDDC Manager UI under Lifecycle Manager > SDDC Manager to confirm that patches for ESXi are now visible.